# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"'((?:([^']*?)\\'[^']*?)*?)'|(?:\\')[^']*'([^']*)'|'([^']*?)'"
test_str = ("'test' \n"
"more'test' \n"
"'test'more \n"
"\\'no'yes' \n"
"a 'one' and 'two' and 'three'... \n"
"nothing at all \n"
"'' \n"
"''test \n"
"test'' \n"
"te''st \n"
"'This is not wrong' and 'this isn\\'t either' \n"
"'tw\\'o repl\\'acements' in 't\\'wo stri\\'ngs'. \n"
"'\\\\'' \n"
"''' \n"
"'test1'\\n'test2' \n"
"'''' \n\n"
"[^\\\\]'([^']*)'|\n\n"
"{;nF, yy]fKAf<6H]T74R}1k#HUIc|]Rqz-Ce72-D%vz&Nm rw=81:1_Y&e,34pL.amQmAoj*m;6ObGN]#u71j%+H\\'}4}b~|nTy]<B7umVMx;tN%QUPY=P`67F4Rert4Cy'PMOJwnmc2s\\'4f<EEmh,yj3Uf/u[lbc/dAgl*Xd%oY,T;+\\\"2_f{BzP`.#v(yGtX\\'O+4eU[P.3&1s+ xm!\n\n\n"
"PMOJwnmc2s")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.