const regex = new RegExp('(?:\\W|^)((?:a|b)(?: +[^ ]+){1,5} +(?:c|d))(?:\\W|$)', 'gm')
const str = `bla a tx fg hg gfgf tzt zt blaa a bli blubb d muh meh muh d"
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}