re = /(?:\W|^)((?:a|b)(?: +[^ ]+){1,5} +(?:c|d))(?:\W|$)/m
str = 'bla a tx fg hg gfgf tzt zt blaa a bli blubb d muh meh muh d"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end