import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?>x|order(?>[\\W_]*number)?[\\W_]*)\\d+(*SKIP)(*F)|(?=(?>[._ –-]*\\d){9})(?>(?>9|6{3}|0{3}|(?>\\d\\D*){3}00|(?>\\d\\D*){5}0{4})(*SKIP)(*F)|\\d(?>\\D*\\d){4})";
final String string = "//won't match if it is preceded with 'X' or 'x'\n"
+ "x123456789\n"
+ "X123456789\n"
+ "x123-456-789\n"
+ "X123-456-789\n"
+ "123-456-789\n"
+ "ordernumber 123-456-789\n"
+ "order number123-456789\n"
+ "order number----123-456789\n"
+ "order number 123456789\n"
+ "ordernumber-x123456787\n"
+ "ordernumber-123456787\n"
+ "ORDERNUMBER-123456789\n"
+ "ordernumber - 123456789\n"
+ "ordernumber #123456789\n"
+ "ordernumber *%&%*123456789\n"
+ "ordernumber !@#$%^&123456789\n"
+ "order.number 123456789\n"
+ "order_number 123456789\n"
+ "order._.number 123456789\n"
+ "order...number#123456789\n"
+ "order-.-.-.-.123456789\n"
+ "order 123456789\n"
+ "order..123456789\n"
+ "order#123456789\n"
+ "order_#123456789\n"
+ "order._.#123456789\n"
+ "order___123456789\n"
+ "order#number 123456789\n"
+ "order......number 123456789\n"
+ "order.number.123456789\n"
+ "social security number 123-456-789\n"
+ "ordernumber !@#$%^&x123456789\n"
+ "123456789\n"
+ "#@%#$%#$123456789#$%#$^$#\n"
+ "123-456789\n"
+ "123456789\n"
+ "123456789\n"
+ "123 45 6789\n"
+ "123-45-6789\n"
+ "123-45-6789\n"
+ "123 – 45 – 6789\n"
+ "123.45.6789\n"
+ "123_45_6789\n"
+ "123 456 789\n"
+ "123-456-789\n"
+ "123 – 456 – 789\n"
+ "123.456.789\n"
+ "123_456_789\n"
+ "1234 56 789\n"
+ "1234-56-789\n"
+ "1234 – 56 – 789\n"
+ "1234.56.789\n"
+ "1234_56_789\n"
+ "12 345 6789\n"
+ "12-345-6789\n"
+ "12 – 345 – 6789\n"
+ "12.345.6789\n"
+ "12_345_6789\n\n"
+ "The number should not be matched at all for the following rules.\n\n"
+ "If the number beginning with the number “9”\n"
+ "912345678\n"
+ "912000000\n\n"
+ "If the number “666” in positions 1 – 3.\n"
+ "666000000\n"
+ "666450000\n"
+ "666129876\n\n"
+ "If the number “000” in positions 1 – 3.\n"
+ "000000000\n"
+ "000450000\n"
+ "000120000\n\n"
+ "If the number “00” in positions 4 – 5.\n"
+ "123006789\n"
+ "876001234\n"
+ "765003456\n\n"
+ "if the number “0000” in positions 6 – 9\n"
+ "123450000\n"
+ "123000000\n"
+ "876000000\n\n"
+ "x123456789\n"
+ "X123456789\n"
+ "x123-456-789\n"
+ "X123-456-789\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}