const regex = /\b(?>x|order(?>[\W_]*number)?[\W_]*)\d+(*SKIP)(*F)|(?=(?>[._ –-]*\d){9})(?>(?>9|6{3}|0{3}|(?>\d\D*){3}00|(?>\d\D*){5}0{4})(*SKIP)(*F)|\d(?>\D*\d){4})/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?>x|order(?>[\\W_]*number)?[\\W_]*)\\d+(*SKIP)(*F)|(?=(?>[._ –-]*\\d){9})(?>(?>9|6{3}|0{3}|(?>\\d\\D*){3}00|(?>\\d\\D*){5}0{4})(*SKIP)(*F)|\\d(?>\\D*\\d){4})', 'gmi')
const str = `//won't match if it is preceded with 'X' or 'x'
x123456789
X123456789
x123-456-789
X123-456-789
123-456-789
ordernumber 123-456-789
order number123-456789
order number----123-456789
order number 123456789
ordernumber-x123456787
ordernumber-123456787
ORDERNUMBER-123456789
ordernumber - 123456789
ordernumber #123456789
ordernumber *%&%*123456789
ordernumber !@#\$%^&123456789
order.number 123456789
order_number 123456789
order._.number 123456789
order...number#123456789
order-.-.-.-.123456789
order 123456789
order..123456789
order#123456789
order_#123456789
order._.#123456789
order___123456789
order#number 123456789
order......number 123456789
order.number.123456789
social security number 123-456-789
ordernumber !@#\$%^&x123456789
123456789
#@%#\$%#\$123456789#\$%#\$^\$#
123-456789
123456789
123456789
123 45 6789
123-45-6789
123-45-6789
123 – 45 – 6789
123.45.6789
123_45_6789
123 456 789
123-456-789
123 – 456 – 789
123.456.789
123_456_789
1234 56 789
1234-56-789
1234 – 56 – 789
1234.56.789
1234_56_789
12 345 6789
12-345-6789
12 – 345 – 6789
12.345.6789
12_345_6789
The number should not be matched at all for the following rules.
If the number beginning with the number “9”
912345678
912000000
If the number “666” in positions 1 – 3.
666000000
666450000
666129876
If the number “000” in positions 1 – 3.
000000000
000450000
000120000
If the number “00” in positions 4 – 5.
123006789
876001234
765003456
if the number “0000” in positions 6 – 9
123450000
123000000
876000000
x123456789
X123456789
x123-456-789
X123-456-789
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}