package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\w+)(-odbc)?://([\w-][\w.-]*)(?::([a-zA-Z0-9]*))?(?:/(\w[\w.-]*)\?([\w\\.#-]*)'&'([\w\\!.#-]*))?$`)
var str = `mssql-odbc://sct-mssql-db.c6p0dl1fqnlk.us-east-1.rds.amazonaws.com:1433/sct_mssql_db?mssql_user'&'schemaconversion
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}