re = /^(\w+)(-odbc)?:\/\/([\w-][\w.-]*)(?::([a-zA-Z0-9]*))?(?:\/(\w[\w.-]*)\?([\w\\.#-]*)'&'([\w\\!.#-]*))?$/m
str = 'mssql-odbc://sct-mssql-db.c6p0dl1fqnlk.us-east-1.rds.amazonaws.com:1433/sct_mssql_db?mssql_user\'&\'schemaconversion
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end