package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<time>\S* \S* \S*) (?<host>[^:]*): (?<priority>[^:]*):(?<message>.*)$`)
var str = `Nov 11 00:18:57 Build01v nagios: SERVICE ALERT: mmj21;Dropwizard MMJ Thread Pool;UNKNOWN;SOFT;1;**Error**: unable to access dropwizard metrics at localhost using port 8001
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}