re = /^(?<time>\S* \S* \S*) (?<host>[^:]*): (?<priority>[^:]*):(?<message>.*)$/m
str = 'Nov 11 00:18:57 Build01v nagios: SERVICE ALERT: mmj21;Dropwizard MMJ Thread Pool;UNKNOWN;SOFT;1;**Error**: unable to access dropwizard metrics at localhost using port 8001
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end