import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:url\\(\\s*\"(_[^\"]+)\"|'(_[^']+)'|(_.+)\\s*\\))";
final String string = "@font-face {\n"
+ " font-family: \"Material Icons\";\n"
+ " font-style: normal;\n"
+ " font-weight: 300;\n"
+ " src: url(MaterialIcons-Regular.eot);\n"
+ " /* For IE6-8 */\n"
+ " src: local(\"Material Icons\"), local(\"MaterialIcons-Regular\"),\n"
+ " url(_MaterialIcons-Regular.woff2) format(\"woff2\"),\n"
+ " url(_MaterialIcons-Regular.woff) format(\"woff\"),\n"
+ " url(_MaterialIcons-Regular.ttf) format(\"truetype\")\n"
+ "}\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}