import Foundation
let pattern = #"(?:url\(\s*"(_[^"]+)"|'(_[^']+)'|(_.+)\s*\))"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
@font-face {
font-family: "Material Icons";
font-style: normal;
font-weight: 300;
src: url(MaterialIcons-Regular.eot);
/* For IE6-8 */
src: local("Material Icons"), local("MaterialIcons-Regular"),
url(_MaterialIcons-Regular.woff2) format("woff2"),
url(_MaterialIcons-Regular.woff) format("woff"),
url(_MaterialIcons-Regular.ttf) format("truetype")
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)