use strict;
my $str = '```json
[
{
"questionType": "singleselect",
"shortDescription": "Who will own the Intellectual Property rights developed during the provision of services?",
"fullDescription": "According to the agreement, who will own the Intellectual Property rights developed during the provision of services?",
"options": [
"The Consultant",
"The Client",
"Both parties"
]
},
{
"questionType": "multipleselect",
"shortDescription": "What are included in Intellectual Property rights according to the agreement?",
"fullDescription": "What are included in Intellectual Property rights according to the agreement? (Select all that apply)",
"options": [
"Patents",
"Design",
"Trademark",
"Know-how",
"Trade secrets",
"Other"
]
},
{
"questionType": "textinput",
"shortDescription": "What rights does the Client have regarding the projects and products resulting from the services?",
"fullDescription": "What specific rights does the Client have regarding the projects and products resulting from the services?",
"options": []
}
]
```';
my $regex = qr/^[^]*?`{3}(?:json)?\n(.*[^]*?)\n`{3}[^]*?$/ip;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}