$re = '/^[^]*?`{3}(?:json)?\n(.*[^]*?)\n`{3}[^]*?$/i';
$str = '```json
[
{
"questionType": "singleselect",
"shortDescription": "Who will own the Intellectual Property rights developed during the provision of services?",
"fullDescription": "According to the agreement, who will own the Intellectual Property rights developed during the provision of services?",
"options": [
"The Consultant",
"The Client",
"Both parties"
]
},
{
"questionType": "multipleselect",
"shortDescription": "What are included in Intellectual Property rights according to the agreement?",
"fullDescription": "What are included in Intellectual Property rights according to the agreement? (Select all that apply)",
"options": [
"Patents",
"Design",
"Trademark",
"Know-how",
"Trade secrets",
"Other"
]
},
{
"questionType": "textinput",
"shortDescription": "What rights does the Client have regarding the projects and products resulting from the services?",
"fullDescription": "What specific rights does the Client have regarding the projects and products resulting from the services?",
"options": []
}
]
```';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);