const regex = /First Name[\s\S](?<firstname>.*)[\s\S]Last Name[\s\S](?<lastname>.*)[\s\S]Phone[\s\S](?<phone>.*)[\s\S]E-Mail[\s\S](?<email>.*)[\s\S]*age group\?[\s\S](?<agegroup>.*)[\s\S]*seeing things up close[\s\S](?<farsightedness>.*)[\s\S]*cannot see very well[\s\S](?<astigmatism>.*)[\s\S]*-Glasses[\s\S](?<glasses>.*)[\s\S]*-Contacts[\s\S](?<contacts>.*)[\s\S]*-Reading Glasses[\s\S](?<readingglasses>.*)[\s\S]*following\?-(?<following>.*)[\s\S]*distance without relying on glasses and contact lenses.[\s\S](?<distance>.*)[\s\S]*close without relying on glasses and contact lenses.[\s\S](?<close>.*)[\s\S]*contacts\?[\s\S](?<wouldyourcareerimprove>.*)[\s\S]*Test Score[\s\S](?<testscore>.*)[\s\S]*Entry ID: (?<entryid>.*)[\s\S].*Referrer: (?<referrer>.*)[\s\S]*Host: (?<formhost>.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('First Name[\\s\\S](?<firstname>.*)[\\s\\S]Last Name[\\s\\S](?<lastname>.*)[\\s\\S]Phone[\\s\\S](?<phone>.*)[\\s\\S]E-Mail[\\s\\S](?<email>.*)[\\s\\S]*age group\\?[\\s\\S](?<agegroup>.*)[\\s\\S]*seeing things up close[\\s\\S](?<farsightedness>.*)[\\s\\S]*cannot see very well[\\s\\S](?<astigmatism>.*)[\\s\\S]*-Glasses[\\s\\S](?<glasses>.*)[\\s\\S]*-Contacts[\\s\\S](?<contacts>.*)[\\s\\S]*-Reading Glasses[\\s\\S](?<readingglasses>.*)[\\s\\S]*following\\?-(?<following>.*)[\\s\\S]*distance without relying on glasses and contact lenses.[\\s\\S](?<distance>.*)[\\s\\S]*close without relying on glasses and contact lenses.[\\s\\S](?<close>.*)[\\s\\S]*contacts\\?[\\s\\S](?<wouldyourcareerimprove>.*)[\\s\\S]*Test Score[\\s\\S](?<testscore>.*)[\\s\\S]*Entry ID: (?<entryid>.*)[\\s\\S].*Referrer: (?<referrer>.*)[\\s\\S]*Host: (?<formhost>.*)', 'gm')
const str = `First Name Melissa
Last Name Madrid
Phone 4253068210
E-Mail Meli.madrid@yahoo.com
What is your age group? 19-39
Without my glasses and contacts-Farsightedness : I have trouble reading and seeing things up close yes
Without my glasses and contacts-Astigmatism : I have distorted vision and cannot see very well yes
What do you usually wear?-Glasses yes
What do you usually wear?-Contacts yes
What do you usually wear?-Reading Glasses yes
Do you have any of the following?-None of the above yes
I would like to see well at a distance without relying on glasses and contact lenses. 5
I would like to see well up close without relying on glasses and contact lenses. 5
Would your career or business activities improve if you were to become less dependent on glasses and contacts? Yes
Test Score -4.00
The message has been sent from 107.77.205.32 (United States) at 2020-01-10 10:39:44 on iPhone unknown
Entry ID: 2190
Referrer: http://m.facebook.com
Form Host: https://www.nweyes.com/landing/smile/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}