import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\|[^\\S\\n]*([^|\\n]*)\\n";
final String string = "EXPRESS blood| muscle| testis| normal| tumor| fetus| adult\n"
+ "RESTR_EXPR soft tissue/muscle tissue tumor";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}