re = /\|[^\S\n]*([^|\n]*)\n/m
str = 'EXPRESS blood| muscle| testis| normal| tumor| fetus| adult
RESTR_EXPR soft tissue/muscle tissue tumor'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end