#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?:Jan(?:uary)?|Feb(?:ruary)?|Mar(?:ch)?|Apr(?:il)?|May|Jun(?:e)?|Jul(?:y)?|Aug(?:ust)?|Sep(?:tember)?|Oct(?:ober)?|(Nov|Dec)(?:ember)?)(\s)([1,2][\d]|[1-9]|30|31)(\s))?(\b[\d]|10|11|12):[0-5][0-9]\s(AM|PM)"
Local $sString = "March 9 12:31 AM and March 10 7:30 AM" & @CRLF & _
"March 11 7:30 AM and March 12 10:30 AM" & @CRLF & _
"Mar 31 9:00 PM and Apr 1 12:39 AM" & @CRLF & _
"March 31 10:11 PM and April 1 5:23 AM" & @CRLF & _
"7:45 PM and 10:30 PM" & @CRLF & _
"May 3 4:41 PM PDT and May 4 12:19 AM PDT" & @CRLF & _
"March 31 10:71 PM and April 1 5:23 AM" & @CRLF & _
"27:45 PM and 10:80 PM" & @CRLF & _
"May 3 4:41 PM PDT and May 41 12:19 AM PDT"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")