import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:Jan(?:uary)?|Feb(?:ruary)?|Mar(?:ch)?|Apr(?:il)?|May|Jun(?:e)?|Jul(?:y)?|Aug(?:ust)?|Sep(?:tember)?|Oct(?:ober)?|(Nov|Dec)(?:ember)?)(\\s)([1,2][\\d]|[1-9]|30|31)(\\s))?(\\b[\\d]|10|11|12):[0-5][0-9]\\s(AM|PM)";
final String string = "March 9 12:31 AM and March 10 7:30 AM\n"
+ "March 11 7:30 AM and March 12 10:30 AM\n"
+ "Mar 31 9:00 PM and Apr 1 12:39 AM\n"
+ "March 31 10:11 PM and April 1 5:23 AM\n"
+ "7:45 PM and 10:30 PM\n"
+ "May 3 4:41 PM PDT and May 4 12:19 AM PDT\n"
+ "March 31 10:71 PM and April 1 5:23 AM\n"
+ "27:45 PM and 10:80 PM\n"
+ "May 3 4:41 PM PDT and May 41 12:19 AM PDT";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}