package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*)SERVICE NOTIFICATION:\s[^;]{5}(.*)`)
var str = `[1571992954] SERVICE NOTIFICATION: nagiosadmin;www.test.com;Elastic_Service_Check;CRITICAL;notify-service-by-email;connect to address xx.xx.xxx.xxx and port 9200: Connection refused`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}