const regex = /^(.*)SERVICE NOTIFICATION:\s[^;]{5}(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*)SERVICE NOTIFICATION:\\s[^;]{5}(.*)', 'gm')
const str = `[1571992954] SERVICE NOTIFICATION: nagiosadmin;www.test.com;Elastic_Service_Check;CRITICAL;notify-service-by-email;connect to address xx.xx.xxx.xxx and port 9200: Connection refused`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}