package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\{?.*?\}`)
var str = `[{"level":"INFO","data": "Test 1"},{"level":"INFO","data": "Test 2"}]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}