re = /\{?.*?\}/
str = '[{"level":"INFO","data": "Test 1"},{"level":"INFO","data": "Test 2"}]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end