const regex = /(?<![^\s.])[a-z]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<![^\\s.])[a-z]', 'gm')
const str = `customer.presentAddress.streetName`;
const subst = `\U\0`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);