use strict;
my $str = 'customer.presentAddress.streetName';
my $regex = qr/(?<![^\s.])[a-z]/mp;
my $subst = '\\U\\0';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";