#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)set \$(\w+)\s+"?(.+?)"?$"
Local $sString = "#========= Variables =========" & @CRLF & _
"set $win Mod4" & @CRLF & _
"set $alt Mod1" & @CRLF & _
"set $ws1 "1"" & @CRLF & _
"set $ws2 "2"" & @CRLF & _
"set $ws3 "3"" & @CRLF & _
"set $ws4 "4"" & @CRLF & _
"set $ws5 "5"" & @CRLF & _
"set $ws6 "6"" & @CRLF & _
"set $ws7 "7"" & @CRLF & _
"set $ws8 "8"" & @CRLF & _
"set $ws9 "9"" & @CRLF & _
"set $ws0 "0"" & @CRLF & _
"set $bar $HOME/.config/polybar/launch.sh" & @CRLF & _
"set $locker i3lock -i $HOME/.config/i3/bg.png" & @CRLF & _
"set $term kitty" & @CRLF & _
"set $menu dmenu -i -l 10" & @CRLF & _
"set $browser qutebrowser" & @CRLF & _
"set $filemanager kitty -e ranger" & @CRLF & _
"set $launcher dmenu_run" & @CRLF & _
"set $notify_daemon dunst" & @CRLF & _
"set $notify_bar_program xob" & @CRLF & _
"set $notify_bar /tmp/xobpipe" & @CRLF & _
"set $script $HOME/.config/i3/scripts" & @CRLF & _
"set $last_action /tmp/i3/last_action" & @CRLF & _
"set $counter /tmp/i3/counter" & @CRLF & _
"set $windows /tmp/i3/windows" & @CRLF & _
"set $current_workspace i3-msg -t get_workspaces | jq -r '.[] | select(.focused==true).name'" & @CRLF & _
"#============================" & @CRLF & _
"" & @CRLF & _
"#======== Autostart =========" & @CRLF & _
"exec nm-applet" & @CRLF & _
"exec kotatogram-desktop" & @CRLF & _
"exec $browser" & @CRLF & _
"exec --no-startup-id dunst" & @CRLF & _
"#============================"
Local $sSubst = "\1="\2""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)