use strict;
my $str = 'aaa_20150229_bbb
aaa_2012-02-29_bbb
aaa_2000-02-29_bbb
aaa_20000229_bbb
2004-2-29
1696-2-29
16960229
aaa_1904229_bbb
aaa_18000229_bbb
aaa_17040229_bbb
aaa_16000229_bbb
2019-3-30
19960229
aaa_20150130_bbb
aaa_20150131_bbb
aaa_2015-04-30_bbb
aaa_20150431_bbb
20190228
20190228
20191112';
my $regex = qr/(?<!\d)
(?:
[0-9]{4}
(?P<sep1>[-/.])?
(?:
(?:(?(sep1)0?|0)[1-9]|1[0-2]) (?(sep1)(?P=sep1)|) (?:(?(sep1)0?|0)[1-9]|1[0-9]|2[0-8])
|(?:(?(sep1)0?|0)[13-9]|1[0-2]) (?(sep1)(?P=sep1)|) (?:29|30)
|(?:(?(sep1)0?|0)[13578]|1[02]) (?(sep1)(?P=sep1)|) (?:31)
)
|
(?:
[0-9]{2}
(?:
0[48]
|[2468][048]
|[13579][26]
)
|(?:
0[48]
|[2468][048]
|[13579][26]
)00
)
(?P<sep2>[-/.]?)
(?(sep2)0?|0)2 (?(sep2)(?P=sep2)|) (?:29)
)
(?!\d)
/mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}