import re
regex = re.compile(r"""
(?<!\d)
(?:
[0-9]{4}
(?P<sep1>[-/.])?
(?:
(?:(?(sep1)0?|0)[1-9]|1[0-2]) (?(sep1)(?P=sep1)|) (?:(?(sep1)0?|0)[1-9]|1[0-9]|2[0-8])
|(?:(?(sep1)0?|0)[13-9]|1[0-2]) (?(sep1)(?P=sep1)|) (?:29|30)
|(?:(?(sep1)0?|0)[13578]|1[02]) (?(sep1)(?P=sep1)|) (?:31)
)
|
(?:
[0-9]{2}
(?:
0[48]
|[2468][048]
|[13579][26]
)
|(?:
0[48]
|[2468][048]
|[13579][26]
)00
)
(?P<sep2>[-/.]?)
(?(sep2)0?|0)2 (?(sep2)(?P=sep2)|) (?:29)
)
(?!\d)
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("aaa_20150229_bbb\n"
"aaa_2012-02-29_bbb\n"
"aaa_2000-02-29_bbb\n"
"aaa_20000229_bbb\n"
"2004-2-29\n"
"1696-2-29\n"
"16960229\n\n"
"aaa_1904229_bbb\n"
"aaa_18000229_bbb\n"
"aaa_17040229_bbb\n"
"aaa_16000229_bbb\n"
"2019-3-30\n"
"19960229\n\n\n"
"aaa_20150130_bbb\n"
"aaa_20150131_bbb\n"
"aaa_2015-04-30_bbb\n"
"aaa_20150431_bbb\n"
"20190228\n"
"20190228\n"
"20191112")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")