#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<ipv6_full>(?:^(?:f[c-f][0-9a-f]{2}|200[1-2]|0?100):).+|(?:.+:0{0,3}1$|(?:.+:ffff:(?:0:)?|^0{0,2}64:ff9b::)(?<ipv4_map>(?:25[0-5]|2[0-4]\d|[0-1]?\d{1,2})(?:\.(?:25[0-5]|2[0-4]\d|[0-1]?\d{1,2})){3})$))"
Local $sString = "::1" & @CRLF & _
"100::" & @CRLF & _
"2001::" & @CRLF & _
"2001:20::" & @CRLF & _
"2001:db8::" & @CRLF & _
"2002::" & @CRLF & _
"fc00::" & @CRLF & _
"fe80::" & @CRLF & _
"ff00::" & @CRLF & _
"64:ff9b::0.0.0.0" & @CRLF & _
"100::" & @CRLF & _
"::ffff:0.0.0.0" & @CRLF & _
"::ffff:0:255.255.255.255"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")