import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<ipv6_full>(?:^(?:f[c-f][0-9a-f]{2}|200[1-2]|0?100):).+|(?:.+:0{0,3}1$|(?:.+:ffff:(?:0:)?|^0{0,2}64:ff9b::)(?<ipv4_map>(?:25[0-5]|2[0-4]\\d|[0-1]?\\d{1,2})(?:\\.(?:25[0-5]|2[0-4]\\d|[0-1]?\\d{1,2})){3})$))";
final String string = "::1\n"
+ "100::\n"
+ "2001::\n"
+ "2001:20::\n"
+ "2001:db8::\n"
+ "2002::\n"
+ "fc00::\n"
+ "fe80::\n"
+ "ff00::\n"
+ "64:ff9b::0.0.0.0\n"
+ "100::\n"
+ "::ffff:0.0.0.0\n"
+ "::ffff:0:255.255.255.255";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}