using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(h[a|à] [n|l][o|ộ]i)";
string input = @"Hà nội mùa này. Bạn em nói ngọng thành Hà lội. Còn Tây họ viết là Ha noi ";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}