re = /(h[a|à] [n|l][o|ộ]i)/mi
str = 'Hà nội mùa này. Bạn em nói ngọng thành Hà lội. Còn Tây họ viết là Ha noi '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end