$re = '/(?<!^using )(System\.)?(Collections\.)?(Generic\.)?(Web\.)?(UI\.)?(WebControls\.)?/m';
$str = 'System.Collections.Generic.List
System.Web.UI.WebControls.Button
using System.Data.SqlClient;
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);