re = /(?<!^using )(System\.)?(Collections\.)?(Generic\.)?(Web\.)?(UI\.)?(WebControls\.)?/m
str = 'System.Collections.Generic.List
System.Web.UI.WebControls.Button
using System.Data.SqlClient;
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end