import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<a(.*)href=(\"|')?(.*?)domainname\\.com(.*)?(\"|'))((\\s)+target=(\"|')?_blank(\"|')?){1}";
final String string = "<a href=\"http://www.domainname.com/\" target=\"_blank\">Hi there</a>\n\n\n"
+ "<a href=\"http://www.otherdomain.com\" target=\"_blank\" class=\"rure-re\">Test 1</a>\n\n\n"
+ "<a target=\"_blank\" href=\"http://www.domainname.com\" class=\"rure-re\">Test 2</a>\n\n\n"
+ "<a href='http://www.domainname.com' class=\"rure-re\" target=\"_blank\">Test 3</a>\n\n\n"
+ "<a target=\"_blank\" id=\"identification\" href='http://www.domainname.com'>Test 4</a>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}