$re = '/(<a(.*)href=("|\')?(.*?)domainname\.com(.*)?("|\'))((\s)+target=("|\')?_blank("|\')?){1}/';
$str = '<a href="http://www.domainname.com/" target="_blank">Hi there</a>
<a href="http://www.otherdomain.com" target="_blank" class="rure-re">Test 1</a>
<a target="_blank" href="http://www.domainname.com" class="rure-re">Test 2</a>
<a href=\'http://www.domainname.com\' class="rure-re" target="_blank">Test 3</a>
<a target="_blank" id="identification" href=\'http://www.domainname.com\'>Test 4</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);