# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\[[[:graph:]]*\] [[:digit:]]{4}\/[[:digit:]]{2}\/[[:digit:]]{2} [[:digit:]]{2}:[[:digit:]]{2}:[[:digit:]]{2}"
test_str = ("[ERROR] 2020/12/07 11:50:43 [TDK 7a9644kyj4t6 6d99a1d9-853c-c4dd-516c-305b6c2ae52f env QCSGERFX023 ip 10.99.98.145 app default] [thread 2603] [HFAPEL] [class VrfParam:1007] [Parameters] A major error occurred while calling the 'callCurrentSession2' function for the 'com.hardis.reflexcs.FMMA00' class from 'HFAPEL': incorrect type\n"
"[ERROR] 2020/12/07 11:50:43 [TDK 7a9644kyj4t6 6d99a1d9-853c-c4dd-516c-305b6c2ae52f env QCSGERFX023 ip 10.99.98.145 app default] [thread 2603] [FMMA00] [class PgmSession:636] Invalid Call 'callCurrentSession2' function of com.hardis.reflexcs.FMMA00\n"
"java.lang.IllegalArgumentException: argument type mismatch\n"
" at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)\n"
" at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)\n"
" at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)\n"
" at java.lang.reflect.Method.invoke(Method.java:498)\n"
" at com.hardis.adelia.template.PgmSession.invokeMethodExtCallExtFuncWithTypeCtrl(PgmSession.java:589)\n"
" at com.hardis.adelia.template.PgmSession.invokeMethodExtCallExtFuncWithTypeCtrl(PgmSession.java:402)\n"
" at com.hardis.reflexcs.HFAPEL._callPgmId_6(HFAPEL.java:789)\n"
" at com.hardis.reflexcs.HFAPEL.UserProcAPPEL_PGM_CLIENT(HFAPEL.java:165)\n"
" at com.hardis.reflexcs.HFAPEL._traiterProcUserProcAPPEL_PGM_CLIENT(HFAPEL.java:661)\n"
" at com.hardis.reflexcs.HFAPEL.initPgm(HFAPEL.java:4478)\n"
" at com.hardis.reflexcs.HFAPEL.javaEntry(HFAPEL.java:4588)\n"
" at com.hardis.reflexcs.HFAPEL.callCurrentSession2(HFAPEL.java:4226)\n"
" at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)\n"
" at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)\n"
" at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)\n"
" at java.lang.reflect.Method.invoke(Method.java:498)\n"
" at com.hardis.adelia.template.PgmSession.invokeMethodExtCallExtFuncWithTypeCtrl(PgmSession.java:589)\n"
" at com.hardis.adelia.template.PgmSession.invokeMethodExtCallExtFuncWithTypeCtrl(PgmSession.java:402)\n"
" at com.hardis.reflexcs.HFEXEP._callPgmId_5(HFEXEP.java:484)\n"
" at com.hardis.reflexcs.HFEXEP$WINDOW01.Obj_IDC_VALIDER_GainFocus(HFEXEP$WINDOW01.java:310)\n"
" at com.hardis.reflexcs.HFEXEP$WINDOW01.dispatchActionNumber(HFEXEP$WINDOW01.java:358)\n"
" at com.hardis.wagon.runtime.Application.dispatchEvent(Application.java:318)\n"
" at com.hardis.wagon.runtime.Application.sendMessage(Application.java:557)\n"
" at com.hardis.adelia.cloud.tools.FocusMgr._setFocusObject(FocusMgr.java:251)\n"
" at com.hardis.adelia.cloud.tools.FocusMgr.setFocusObject(FocusMgr.java:161)\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.