re = /^\[[[:graph:]]*\] [[:digit:]]{4}\/[[:digit:]]{2}\/[[:digit:]]{2} [[:digit:]]{2}:[[:digit:]]{2}:[[:digit:]]{2}/m
str = '[ERROR] 2020/12/07 11:50:43 [TDK 7a9644kyj4t6 6d99a1d9-853c-c4dd-516c-305b6c2ae52f env QCSGERFX023 ip 10.99.98.145 app default] [thread 2603] [HFAPEL] [class VrfParam:1007] [Parameters] A major error occurred while calling the \'callCurrentSession2\' function for the \'com.hardis.reflexcs.FMMA00\' class from \'HFAPEL\': incorrect type
[ERROR] 2020/12/07 11:50:43 [TDK 7a9644kyj4t6 6d99a1d9-853c-c4dd-516c-305b6c2ae52f env QCSGERFX023 ip 10.99.98.145 app default] [thread 2603] [FMMA00] [class PgmSession:636] Invalid Call \'callCurrentSession2\' function of com.hardis.reflexcs.FMMA00
java.lang.IllegalArgumentException: argument type mismatch
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at com.hardis.adelia.template.PgmSession.invokeMethodExtCallExtFuncWithTypeCtrl(PgmSession.java:589)
at com.hardis.adelia.template.PgmSession.invokeMethodExtCallExtFuncWithTypeCtrl(PgmSession.java:402)
at com.hardis.reflexcs.HFAPEL._callPgmId_6(HFAPEL.java:789)
at com.hardis.reflexcs.HFAPEL.UserProcAPPEL_PGM_CLIENT(HFAPEL.java:165)
at com.hardis.reflexcs.HFAPEL._traiterProcUserProcAPPEL_PGM_CLIENT(HFAPEL.java:661)
at com.hardis.reflexcs.HFAPEL.initPgm(HFAPEL.java:4478)
at com.hardis.reflexcs.HFAPEL.javaEntry(HFAPEL.java:4588)
at com.hardis.reflexcs.HFAPEL.callCurrentSession2(HFAPEL.java:4226)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at com.hardis.adelia.template.PgmSession.invokeMethodExtCallExtFuncWithTypeCtrl(PgmSession.java:589)
at com.hardis.adelia.template.PgmSession.invokeMethodExtCallExtFuncWithTypeCtrl(PgmSession.java:402)
at com.hardis.reflexcs.HFEXEP._callPgmId_5(HFEXEP.java:484)
at com.hardis.reflexcs.HFEXEP$WINDOW01.Obj_IDC_VALIDER_GainFocus(HFEXEP$WINDOW01.java:310)
at com.hardis.reflexcs.HFEXEP$WINDOW01.dispatchActionNumber(HFEXEP$WINDOW01.java:358)
at com.hardis.wagon.runtime.Application.dispatchEvent(Application.java:318)
at com.hardis.wagon.runtime.Application.sendMessage(Application.java:557)
at com.hardis.adelia.cloud.tools.FocusMgr._setFocusObject(FocusMgr.java:251)
at com.hardis.adelia.cloud.tools.FocusMgr.setFocusObject(FocusMgr.java:161)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end