import re
regex = re.compile(r"(?s)(?<=\<span class=\"highlight highlight--wrapping\"\>)(.*?)(?=\<\/span\>)")
test_str = ("<div>... <span class=\"highlight highlight--wrapping\">Chuck</span> <span class=\"highlight highlight--wrapping\">Feeney</span> (David Cantwell for Forbes) \n\n"
"On a cool summer afternoon at Dublin's Heuston Station, <span class=\"highlight highlight--wrapping\">Chuck</span> <span class=\"highlight highlight--wrapping\">Feeney</span>, 81...<br> slowly limped out of the station completely unnoticed. And that's just how <span class=\"highlight highlight--wrapping\">Feeney</span> likes it.\n"
"<span class=\"highlight highlight--wrapping\">Chuck</span> <span class=\"highlight highlight--wrapping\">Feeney</span> is the James ...</div>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")