const regex = /\b(in relation to any Facility [A-Z] Loan \[\s*(\d+%)\s*\] per cent. per annum);/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(in relation to any Facility [A-Z] Loan \\[\\s*(\\d+%)\\s*\\] per cent. per annum);', 'gm')
const str = `"Margin" means:
(a) in relation to any Facility A Loan [2% ] per cent. per annum;
(b) in relation to any Facility B Loan [ 5% ] per cent. per annum;
(c) [in relation to any Incremental Facility Loan, the percentage rate per annum specified as such in the Incremental Facility Notice relating to the Incremental Facility under which that Incremental Facility Loan is made or is to be made;]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}