re = /\b(in relation to any Facility [A-Z] Loan \[\s*(\d+%)\s*\] per cent. per annum);/m
str = '"Margin" means:
(a) in relation to any Facility A Loan [2% ] per cent. per annum;
(b) in relation to any Facility B Loan [ 5% ] per cent. per annum;
(c) [in relation to any Incremental Facility Loan, the percentage rate per annum specified as such in the Incremental Facility Notice relating to the Incremental Facility under which that Incremental Facility Loan is made or is to be made;]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end