package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\(default\)(.+?([A-Z]{2,4}).+?([A-Z]{2,4})|.+?([A-Z]{2,4}))`)
var str = `(default) AA / BBB)
ASDF / XYZ / GE
(default) CCCC)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}