re = /\(default\)(.+?([A-Z]{2,4}).+?([A-Z]{2,4})|.+?([A-Z]{2,4}))/m
str = '(default) AA / BBB)
ASDF / XYZ / GE
(default) CCCC)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end