#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[!-\/:-@[-`{-~]"
Local $sString = " ! U+0021 EXCLAMATION MARK" & @CRLF & _
" " U+0022 QUOTATION MARK" & @CRLF & _
" # U+0023 NUMBER SIGN" & @CRLF & _
" $ U+0024 DOLLAR SIGN" & @CRLF & _
" % U+0025 PERCENT SIGN" & @CRLF & _
" & U+0026 AMPERSAND" & @CRLF & _
" ' U+0027 APOSTROPHE" & @CRLF & _
" ( U+0028 LEFT PARENTHESIS" & @CRLF & _
" ) U+0029 RIGHT PARENTHESIS" & @CRLF & _
" * U+002A ASTERISK" & @CRLF & _
" + U+002B PLUS SIGN" & @CRLF & _
" , U+002C COMMA" & @CRLF & _
" - U+002D HYPHEN-MINUS" & @CRLF & _
" . U+002E FULL STOP" & @CRLF & _
" / U+002F SOLIDUS" & @CRLF & _
" : U+003A COLON" & @CRLF & _
" ; U+003B SEMICOLON" & @CRLF & _
" < U+003C LESS-THAN SIGN" & @CRLF & _
" = U+003D EQUALS SIGN" & @CRLF & _
" > U+003E GREATER-THAN SIGN" & @CRLF & _
" ? U+003F QUESTION MARK" & @CRLF & _
" @ U+0040 COMMERCIAL AT" & @CRLF & _
" [ U+005B LEFT SQUARE BRACKET" & @CRLF & _
" \ U+005C REVERSE SOLIDUS" & @CRLF & _
" ] U+005D RIGHT SQUARE BRACKET" & @CRLF & _
" ^ U+005E CIRCUMFLEX ACCENT" & @CRLF & _
" _ U+005F LOW LINE" & @CRLF & _
" ` U+0060 GRAVE ACCENT" & @CRLF & _
" { U+007B LEFT CURLY BRACKET" & @CRLF & _
" | U+007C VERTICAL LINE" & @CRLF & _
" } U+007D RIGHT CURLY BRACKET" & @CRLF & _
" ~ U+007E TILDE"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")