import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[!-\\/:-@[-`\\{-~]";
final String string = " ! U+0021 EXCLAMATION MARK\n"
+ " \" U+0022 QUOTATION MARK\n"
+ " # U+0023 NUMBER SIGN\n"
+ " $ U+0024 DOLLAR SIGN\n"
+ " % U+0025 PERCENT SIGN\n"
+ " & U+0026 AMPERSAND\n"
+ " ' U+0027 APOSTROPHE\n"
+ " ( U+0028 LEFT PARENTHESIS\n"
+ " ) U+0029 RIGHT PARENTHESIS\n"
+ " * U+002A ASTERISK\n"
+ " + U+002B PLUS SIGN\n"
+ " , U+002C COMMA\n"
+ " - U+002D HYPHEN-MINUS\n"
+ " . U+002E FULL STOP\n"
+ " / U+002F SOLIDUS\n"
+ " : U+003A COLON\n"
+ " ; U+003B SEMICOLON\n"
+ " < U+003C LESS-THAN SIGN\n"
+ " = U+003D EQUALS SIGN\n"
+ " > U+003E GREATER-THAN SIGN\n"
+ " ? U+003F QUESTION MARK\n"
+ " @ U+0040 COMMERCIAL AT\n"
+ " [ U+005B LEFT SQUARE BRACKET\n"
+ " \\ U+005C REVERSE SOLIDUS\n"
+ " ] U+005D RIGHT SQUARE BRACKET\n"
+ " ^ U+005E CIRCUMFLEX ACCENT\n"
+ " _ U+005F LOW LINE\n"
+ " ` U+0060 GRAVE ACCENT\n"
+ " { U+007B LEFT CURLY BRACKET\n"
+ " | U+007C VERTICAL LINE\n"
+ " } U+007D RIGHT CURLY BRACKET\n"
+ " ~ U+007E TILDE";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}