package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d\. `)
var str = `1. Wariancja – co to jest wariancja, jak się ją wyjaśnia i co to jest model.
2. Testy statystyczne i wartość *p* – jak działają testy statystyczne, co to jest *p* i jak je interpretować.
3. Kombinatoryka – krótkie omówienie podstawowych terminów kombinatoryki, może być 1. wprowadzeniem do prawdopodobieństwa.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}