$re = '/^\d\. /m';
$str = '1. Wariancja – co to jest wariancja, jak się ją wyjaśnia i co to jest model.
2. Testy statystyczne i wartość *p* – jak działają testy statystyczne, co to jest *p* i jak je interpretować.
3. Kombinatoryka – krótkie omówienie podstawowych terminów kombinatoryki, może być 1. wprowadzeniem do prawdopodobieństwa.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);