$re = '/^(?:bool|double|int(?!.*?([0-9a-z])\1))\s+(?:\b[A-Z](?!\w*___)[0-9a-z_]+,?\s*){1,5}\b;$/m';
$str = ' Valid:
int Xy;
double A1b, B_2;
bool Cx, D3_z;
Invalid:
int X;
int X___y;
int XY;
int X11;
double 1A;
int Xy, A1b, B_2, C3_d, D4e, E5f;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);