import re
regex = re.compile(r"^(?:bool|double|int(?!.*?([0-9a-z])\1))\s+(?:\b[A-Z](?!\w*___)[0-9a-z_]+,?\s*){1,5}\b;$", flags=re.MULTILINE)
test_str = (" Valid:\n"
"int Xy;\n"
"double A1b, B_2;\n"
"bool Cx, D3_z;\n\n"
"Invalid:\n"
"int X;\n"
"int X___y;\n"
"int XY;\n"
"int X11;\n"
"double 1A;\n"
"int Xy, A1b, B_2, C3_d, D4e, E5f;")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")