import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".+(?P<src_ip>\\d*\\.\\d*\\.\\d*\\.\\d*)(?:\\.(?P<src_port>\\d*))?.>.(?P<dst_ip>\\d*\\.\\d*\\.\\d*\\.\\d*)(?:\\.(?P<dst_port>\\d*))?:\\.*";
final String string = "10:14:48.983541 IP 10.242.136.232.34266 > 10.81.163.129.9200: Flags [S], seq 2294574211, win 29200, options [mss 1460,sackOK,TS val 22536912 ecr 0,nop,wscale 7], length 0\n"
+ "10:14:48.983541 IP 10.242.136.232 > 10.81.163.129.9200: fictional stuff\n"
+ "10:14:48.983541 IP 10.242.136.232 > 10.81.163.129: also fictional stuff\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}