$re = '/\bInvoked at: \K[^#]*\d/m';
$str = '### Invoked at: Wed Dec 7 22:24:35 2022 ###';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);